Issue409

Title Spam on jython tracker.
Priority urgent Status resolved
Superseder Nosy List amak, ezio.melotti, loewis
Assigned To Topics

Created on 2011-07-16.19:19:35 by amak, last changed 2012-04-02.15:25:16 by loewis.

Messages
msg2112 (view) Author: amak Date: 2011-07-16.19:19:35
There are 4 bugs in jython tracker that are spam.

Example, Issue 1773, "cheap discount tramadol free shipping buy cheap tramadol online at lowest price us"

Please can someone delete these as a matter of urgency.

Alternatively, give me the priviledges to delete them myself, I'm a jython committer and watch the bugs list all the time.
msg2113 (view) Author: ezio.melotti Date: 2011-07-16.19:54:33
You should already have Developer privileges on the Jython bug tracker for the 'amak' account.
Usually you just close the issue, remove the message(s) and change the title to e.g. "spam".
msg2114 (view) Author: amak Date: 2011-07-16.20:13:37
OK, thanks, I did that, i.e. changed the subjects and closed them.

I tried to delete the messages and attachments, full of spam links. But I got an "Invalid request" error. Any ideas why?
msg2115 (view) Author: loewis Date: 2011-07-17.07:45:40
> You should already have Developer privileges on the Jython bug tracker for the 'amak' account.
> Usually you just close the issue, remove the message(s) and change the title to e.g. "spam".

That's not appropriate. If the message is removed, it remains accessible
under it's message URL. It needs to be retired, or
marked as spam.
msg2116 (view) Author: amak Date: 2011-07-17.12:09:11
> If the message is removed, it remains accessible
> under it's message URL. It needs to be retired, or
> marked as spam.

Yes, I would definitely prefer for the entire issues to simply be deleted.

However, there does not seem to be a "Delete Issue" capability, or at least none is offered to me at my priviledge level. What do you mean by "retire"?

As well as changing the title and closing the offending issues, I also tried to "Remove" both the individual messages and the HTML attachments on the issues, which were full of spammy links. However, both of these failed with an "Invalid request" error. Is this a bug in roundup? Or do I simply not have the privs for this operation?
msg2117 (view) Author: loewis Date: 2011-07-18.07:01:53
> Yes, I would definitely prefer for the entire issues to simply be
> deleted.

Deletion is not supported in Roundup, by design. It's always possible to
bring things back.

Also, deletion of the issue would still keep the messages and files
available.

> What do you mean by "retire"?

Retiring is Roundup's equivalent of deletion. The object becomes
unavailable (but can be restored). It can only be invoked from the
command line.

> I also tried to "Remove" both the individual messages and the HTML
> attachments on the issues, which were full of spammy links. However,
> both of these failed with an "Invalid request" error. Is this a bug
> in roundup?

Probably so.
msg2118 (view) Author: ezio.melotti Date: 2011-07-19.20:14:28
Should we retire those issues, messages and files then?

I was trying to retire a file doing
  roundup> retire fileXXX
  roundup> commmit
from roundup-admin on my local tracker but even if I see 
  Date                 User   Action   Args
  2011-07-19 20:05:20  admin  retired  None
in the file history, the file is still linked to issue, I can still access it, and the id is not reused when another file is attached.

I also tried to unlink the file from the issue with
  roundup> set issueXXX files=-YYY
and 
  /issueXXX?@action=edit&@remove@files=YYY
but they both failed (also a few variants of these weren't successful).
msg2121 (view) Author: amak Date: 2011-07-19.20:50:46
[Elio]
> Should we retire those issues, messages and files then?

If that's the way for them to cease to exist, then please, yes. I just want for them to disappear.

They serve no purpose other than to pollute the jython tracker, lower our estimation in the eyes of jython users, lower our search engine ranking, and promote the activities of an illegal drug merchant.

[Elio]
> I was trying to retire a file doing
>   roundup> retire fileXXX
>   roundup> commmit
> from roundup-admin on my local tracker but even if I see 
>   Date                 User   Action   Args
>   2011-07-19 20:05:20  admin  retired  None
> in the file history, the file is still linked to issue, I can still access it, and the id is not reused when another file is attached.
> 
> I also tried to unlink the file from the issue with
>   roundup> set issueXXX files=-YYY
> and 
>   /issueXXX?@action=edit&@remove@files=YYY
> but they both failed (also a few variants of these weren't successful).

I'm afraid I don't know enough about roundup to assist with these issues.

Thanks for your help.

Alan.
msg2163 (view) Author: ezio.melotti Date: 2011-07-25.02:22:00
FWIW I just got an error while trying to remove a file from #119 (using the remove button).  Maybe both this and the Jython tracker require Admin privileges to remove files submitted by others.

Martin, do you know how to retire those files/messages?
msg2209 (view) Author: ezio.melotti Date: 2011-08-08.23:29:34
The problem with the files was that it required a POST request while the remove button was trying to use GET.  This is now fixed in r88878 in both the Jython and meta trackers, so you can remove files and messages from the issues.

OTOH I still haven't figured out how to retire those issue/messages/files.
msg2422 (view) Author: loewis Date: 2012-04-02.15:25:16
Retiring the message had not the desired effect; it merely makes it unavailable for listing. I have now restored the Spam button, and marked the files and the message as spam.
History
Date User Action Args
2012-04-02 15:25:16loewissetstatus: chatting -> resolved
messages: + msg2422
2011-08-08 23:29:34ezio.melottisetmessages: + msg2209
2011-07-25 02:22:00ezio.melottisetmessages: + msg2163
2011-07-19 20:50:46amaksetmessages: + msg2121
2011-07-19 20:14:28ezio.melottisetmessages: + msg2118
2011-07-18 07:01:53loewissetmessages: + msg2117
2011-07-17 12:09:11amaksetmessages: + msg2116
2011-07-17 07:45:40loewissetnosy: + loewis
messages: + msg2115
2011-07-16 20:13:37amaksetmessages: + msg2114
2011-07-16 19:54:33ezio.melottisetstatus: unread -> chatting
nosy: + ezio.melotti
messages: + msg2113
2011-07-16 19:19:35amakcreate